Resolved: Incident on the PCI Proxy platform

Incident Report for PCI Proxy

Resolved

Dear customer,

We experienced problems with DNS resolution impacting transaction processing on the PCI Proxy platform.
Duration: 21 June 2025, 00:44 - 04:59 CET

Please excuse the inconveniences caused.

Best regards,
PCI Proxy
Posted Jun 21, 2025 - 05:52 UTC