Update on Connectivity Enhancements and RCA Status

Incident Report for PCI Proxy

Resolved

Dear customer

As part of our ongoing efforts to improve service reliability, we completed a network failover at 04:00 CEST on 4th June. We're pleased to report that the transition was successful and caused no disruption to our services.

This change is part of a broader initiative to address recent connectivity issues that affected some customers' incoming and outgoing connections. By switching to a more stable network line, we aim to ensure a more consistent and resilient service experience moving forward.

Since then we didn't experience any other connectivity issue and our teams continue to closely monitor all systems and are actively investigating the root cause of the issues impacting the primary link. We will share a full Root Cause Analysis (RCA) as soon as our investigation is complete.

Thank you for your patience and continued trust.

Best regards,

The PCI Proxy team
Posted Jun 13, 2025 - 05:41 UTC