Incident on the PCI Proxy platform

Incident Report for PCI Proxy

Resolved

Dear customer,

Our services are back up since since 09:55:20 CET
Downtime was 09:30:20 - 09:55:20 CET

We will provide an RCA in the following days.

Best regards,
the PCI Proxy team
Posted Jun 23, 2025 - 08:10 UTC

Update

Dear customer,

our services are up again.
We will continue our investigations and provide the results in the following days.

Best regards,
The PCI Proxy team.
Posted Jun 23, 2025 - 07:58 UTC

Investigating

Dear customer,

We detected an incident on our platform.
Our colleagues are currently investigating and we will update as soon as we have details.

Best regards,
The PCI Proxy team
Posted Jun 23, 2025 - 07:35 UTC