The issue affecting the PCI Proxy platform has been resolved. All services are operating normally at this time.
Start time: June 20th, 10:09:59 CET End time: June 20th, 11:02:59 CET
We will share more details about the incident once our internal review is complete.
Thank you for your patience while we worked to restore full functionality.
Best regards, The PCI Proxy team
Posted Jun 20, 2025 - 09:08 UTC
Update
Dear customer,
Our team is continuing to investigate the issue on the PCI Proxy platform. We are actively working to identify the root cause and will share further updates as soon as we have more details.
Thank you for your continued patience – we understand the importance of resolving this promptly and will keep you informed.
Best regards, The PCI Proxy team.
Posted Jun 20, 2025 - 08:40 UTC
Investigating
Dear customer,
We are currently experiencing an issue on the PCI Proxy platform. Our technical team is actively investigating the cause and working to resolve it as quickly as possible.
We will provide updates as soon as more information becomes available.