Incident on the PCI Proxy platform

Incident Report for PCI Proxy

Resolved

Dear customer,

Our services are back up since since 09:28 CET

Downtime was 09:28 - 10:19 CET

We will provide an RCA in the following days.

Best regards,
the PCI Proxy team
Posted Jul 05, 2025 - 08:05 UTC

Investigating

Dear customer,

We are currently experiencing an issue on the PCI Proxy platform.
Our technical team is actively investigating the cause and working to resolve it as quickly as possible.

We will provide updates as soon as more information becomes available.

Thank you for your patience.

Best regards,

The PCI Proxy team.
Posted Jul 05, 2025 - 07:40 UTC